Technology Requirements

This site may be viewed on a PC, Macintosh, or graphical UNIX computer that is capable of running standard Internet browsers. A connection to the Internet (33.6 modem or better) is required, as well. Faster modems and DSL/Cable/T1 connections will yield an improved experience.

Our FAOS DLearning modules requires the latest versions of Internet Explorer, Microsoft Edge, Firefox, Google Chrome, Opera, or Safari.

Some of our websites include audio. For these, we require an audio player that can support .wma files.